Module 0: Install GeoDMS GUI and setup a configuration

From ObjectVision

(Difference between revisions)
Jump to: navigation, search
Line 1: Line 1:
-
==''Install GeoDMS''==
+
===''Install GeoDMS''===
# Download the most recent version of GeoDMS [[GeoDms Setups|here]]
# Download the most recent version of GeoDMS [[GeoDms Setups|here]]
Line 17: Line 17:
-
==''Load configuration''==
+
===''Load configuration''===
# Download an existing configuration
# Download an existing configuration
Line 23: Line 23:
# Then it should like this:  "C:/GeoDMS/ProjDir/Vesta/cfg/stam.dms"
# Then it should like this:  "C:/GeoDMS/ProjDir/Vesta/cfg/stam.dms"
-
==''Open configuration''==
+
===''Open configuration''===
# Open GeoDMS GUI
# Open GeoDMS GUI
# Go to File > Open configuration file and navigate to and open, for example: "C:/GeoDMS/ProjDir/Vesta/cfg/stam.dms"
# Go to File > Open configuration file and navigate to and open, for example: "C:/GeoDMS/ProjDir/Vesta/cfg/stam.dms"
-
==''Setup a configuration editor''==
+
===''Setup a configuration editor''===
The GeoDMS GUI has a neat feature to jump to the correct line in the configuration files from the GUI using CTRL + e, or right-clicking > Edit config source.
The GeoDMS GUI has a neat feature to jump to the correct line in the configuration files from the GUI using CTRL + e, or right-clicking > Edit config source.

Revision as of 13:43, 10 August 2020

Contents

Install GeoDMS

  1. Download the most recent version of GeoDMS here
  2. Install the software
  3. Open GeoDMS
  4. Check all the boxes in Tools > Options, like this:

File:Website_InstallatieManual_Settings.png



Don't you want GeoDMS to look for SourceData in C:/SourceData or LocalData in C:/LocalData? Then in the GeoDMS GUI go to Tools > Options and change the paths at the bottom:

File:Website_InstallatieManual_Paths.png



Load configuration

  1. Download an existing configuration
  2. Place it in your ProjDir-folder, for example "C:/GeoDMS/ProjDir/Vesta"
  3. Then it should like this: "C:/GeoDMS/ProjDir/Vesta/cfg/stam.dms"

Open configuration

  1. Open GeoDMS GUI
  2. Go to File > Open configuration file and navigate to and open, for example: "C:/GeoDMS/ProjDir/Vesta/cfg/stam.dms"

Setup a configuration editor

The GeoDMS GUI has a neat feature to jump to the correct line in the configuration files from the GUI using CTRL + e, or right-clicking > Edit config source.

We recommend using the text editor Notepad++, which can be downloaded [here]. Then you can download the GeoDMS language file here: [GeoDMS/dev/res/NotePadPlusPlus] (username: guest, password: guest, if you see the xml-code, go back and save target as.

To import the language file in Notepad++, open Notepad++ and go to Language > User defined Language > Define your language. There click import and select the just download .xml-file. Then to use the language go to language and select at the bottom GeoDMS.

To make sure GeoDMS understands where Notepad++ is installed, make your the reference is correct in the GeoDMS options, for example:

C:\Program Files\Notepad++\Notepad++.exe "%F" -n%L


File:GeoDMS option txteditor.png


Go to next module: Module 1: Learning the basic concepts of GeoDMS

Personal tools